首页 > wordpress教程 > php 5.2.4安装wordPress程序的解决办法
摘要:在服务器上安装WORDPRESS时,提示您的服务器PHP版本是5.2.3,但WordPress 3.3.2需要5.2.4...

在服务器上安装WORDPRESS时,提示您的服务器PHP版本是5.2.3,但WordPress 3.3.2需要5.2.4以上版本
Your server is running PHP version 5.2.0 but WordPress 3.3.2 requires at least 5.2.4.

解决办法:
第1种办法:直接修改版本限制:
wordpress\wp-includes\version.php中,将
$required_php_version = ’5.2.4′;

修改为
$required_php_version = ’5.2.0′;
(上面的方法,为机械式的更改,有掩耳盗铃的嫌疑,会影响后期的稳定性,不过也算是临时解决办法)
第2种办法:直接升级PHP
注意,只能将php 5.2.0升级为5.2.x版本,不要升级为php 5.3.x及以上的版本,因为php 5.3.x及以上的版本设计重新变化过,是分水岭。

先下载php 5.2.5, http://www.php100.com/html/download/tools/2009/0409/40.html
再停止apache服务器,防止它加载了php的dll文件,而不能覆盖;(如果是IIS,则先停止IIS服务)
把php-5.2.5-Win32.zip里的所有文件拷贝覆盖到PHP安装目录如C:\PHP下(注意,不要破坏C:\Windows\php.ini)

重新启动apache,启动成功(如果是IIS,则启动IIS服务),说明PHP升级为php 5.2.3成功。
运行phpinfo()函数,可以见到PHP的版本号为5.2.3,放心了。

分享到:
赞(0) 打赏

作者: 大挖酱

挖主题团队自2014年开始专注于WordPress企业主题设计开发,致力于为更多用户打造出更漂亮、更易用、更专业的网站。距今已累计开发近50款WP主题,付费客户超过5千人。挖主题,是您可以长期信赖的合作伙伴。

付款后联系作者QQ 2243748

支付宝扫一扫

微信扫一扫